IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
Dash A/c Ventss Will Not Open, After installing new battery dash A/C vents will not open
Stradibarrius
post Jul 5 2017, 01:40 PM
Post #1


Member
***

Group: Members
Posts: 53
Joined: 17-December 16
Member No.: 22,339



2003 Tahoe Z71 that I bought new.
My battery died so I went to the auto parts store and bought a new battery. The guy there even changed it for me. In 10 minutes it was done, BUT, there is always a big but! When I got back in and started up as I headed to my next errand I realized that my A/C was only coming from the defrost vents. I tried selecting all of the options from the defrost, floor, in your face and the only place the air came out was the defrost vents.
Any ideas as to what I can do to get this working right. It seems this may have happened befor
Go to the top of the page
 
+Quote Post
Scott
post Jul 5 2017, 02:18 PM
Post #2


Needs a Life!
**********

Group: Admin
Posts: 16,459
Joined: 8-June 04
From: NW Chicago Burbs
Member No.: 2



There is a actuator recalibration procedure you can try. I cannot remember the process exactly, but pull the HVAC fuse(s), wait a few minutes, start the engine and let it run the cycle. Search for the exact steps, and try it a few times and see if you get lucky. If not, you might have to change the stuck actuator. The good news is, it's not the temp blend door actuator which is a freaking bear to replace.


--------------------
2004 Z71 Tahoe Black
~ Bunch of Mods ~
Go to the top of the page
 
+Quote Post
Stradibarrius
post Jul 15 2017, 06:39 AM
Post #3


Member
***

Group: Members
Posts: 53
Joined: 17-December 16
Member No.: 22,339



I tried pulling the fuses. Sometimes when you first turn on the Ac it will blow through the front vents but then goes back to blowing through the defrost vents only. Do you think if I disconnected the battery and re connected, it would do it?
Go to the top of the page
 
+Quote Post
Scott
post Jul 17 2017, 09:19 AM
Post #4


Needs a Life!
**********

Group: Admin
Posts: 16,459
Joined: 8-June 04
From: NW Chicago Burbs
Member No.: 2



QUOTE (Stradibarrius @ Jul 15 2017, 07:39 AM) *
I tried pulling the fuses. Sometimes when you first turn on the Ac it will blow through the front vents but then goes back to blowing through the defrost vents only. Do you think if I disconnected the battery and re connected, it would do it?


You can certainly try. But again, I'd recommend searching here for the "Actuator Calibration" procedure, and follow that. If that doesn't work after trying a few times, you pretty well have confirmed the actuator is bad.


--------------------
2004 Z71 Tahoe Black
~ Bunch of Mods ~
Go to the top of the page
 
+Quote Post
subdrvr
post Jul 17 2017, 05:24 PM
Post #5


Member
***

Group: Members
Posts: 81
Joined: 13-February 11
From: Durham NC
Member No.: 13,303



One other thing you might try is to have the BCM reflashed to make sure it has all of the updates. My '04 had this type of problem chronically since new and one of the dealer's attempted fixes involved reprogramming for a problem they called "overtravel" of the actuators. 7 or 8 actuators under warranty and it would have been more if Id had time to take it in more often. The fix Scott is referring to has worked for me since. If the A/C air is making it to the dash vents at least temporarily, that suggests they work and are being commanded incorrectly.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic

 



RSS Lo-Fi Version Time is now: 19th August 2017 - 10:09 PM