IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
Right Signal Doesnít Cancel Out
Marky421
post Jan 7 2018, 03:16 AM
Post #1


Newbie
*

Group: Members
Posts: 4
Joined: 7-January 18
Member No.: 22,981



I bought a new cruise/turn signal switch from eBay. Iím sure itís not oem. Had to switch it because the high beam would turn on every time I signaled right with the headlights on. I switched it and now if I do a full turn right it doesnít self cancel. But it does cancel if I do a slight turn. Is it the switch or the install? Anyone else experience this?
Go to the top of the page
 
+Quote Post
Gary P
post Jan 8 2018, 05:23 AM
Post #2


Needs a Life!
**********

Group: Supporting Member
Posts: 14,605
Joined: 10-September 05
From: Endicott, NY
Member No.: 1,460



Mark - I can't help with your question, as I am terrible at electrical stuff, but I do want to welcome you to the forum! welcome-z71ts.gif
There's a great bunch of folks here, so hopefully someone with some electrical background will chime in.

Once again, WELCOME!


--------------------
2012 Summit White Silverado 2500HD 4WD Z71 Crew Cab, New 8/31/12 ... with a Black Bear Performance tune - Love it!
2005 Summit White Tahoe 4WD Z71 (For the wife.... finally!)

2002 Silverado 1500 LS, Ext cab, 4WD...Gone, but not forgotten.... SOLD 8/31/12

How to Donate to Z71T-S.com ==>
http://z71tahoe-suburban.com/iboard/index....c=25714&hl=
Go to the top of the page
 
+Quote Post
Marky421
post Jan 9 2018, 12:04 PM
Post #3


Newbie
*

Group: Members
Posts: 4
Joined: 7-January 18
Member No.: 22,981



QUOTE (Gary P @ Jan 8 2018, 03:23 AM) *
Mark - I can't help with your question, as I am terrible at electrical stuff, but I do want to welcome you to the forum! welcome-z71ts.gif
There's a great bunch of folks here, so hopefully someone with some electrical background will chime in.

Once again, WELCOME!

Thank you
Go to the top of the page
 
+Quote Post
carguru
post Jan 9 2018, 02:25 PM
Post #4


Needs a Life!
**********

Group: Moderators
Posts: 13,186
Joined: 2-July 04
From: Cary, NC
Member No.: 18



Either the part has a defect or something didn't align in reassembly. That would be my guess.


--------------------
DC
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic

 



RSS Lo-Fi Version Time is now: 18th January 2018 - 02:10 AM